• The July 2024 Lotus Emira of the Month contest is underway! Please take a moment to check out thread here: 🏆 July 2024 - Emira of the Month starts now! (You can dismiss this message by clicking the X in the top right hand corner of this notice.)

The engine fault light remains on.

Vpower10

Member
Joined
Aug 2, 2023
Messages
24
Reaction score
78
Location
Belgium
Emira Status
Emira Owner
My car has now driven 14,000 km and has already had several updates. A final update last week. But even before this update and now the last one last week, the engine fault light keeps coming on. Last time my garage told me that this was not a problem and that this would be addressed in the next update. But after the last update last week it went away for a while, after about 100 km it suddenly came back and stayed. The car drives perfectly and does not indicate that anything is wrong. After a phone call to the garage, they went to Lotus to listen to how this could happen because they were apparently aware of it. In any case, this has to go because it always seems like there is something wrong with the car. Anyone else having this problem?

Icoon voor Geverifieerd door de community
 

Attachments

  • engine light.jpg
    engine light.jpg
    223.1 KB · Views: 54
  • Thread Starter
  • Thread starter
  • #3
Get a OBD II reader
ok thanks for the response, can you specifically recommend one to me and I will order it. I don't know anything about it myself, but can I easily see why the engine warning light comes on, what causes the fault?

Icoon voor Geverifieerd door de community
 
ok thanks for the response, can you specifically recommend one to me and I will order it. I don't know anything about it myself, but can I easily see why the engine warning light comes on, what causes the fault?
Most of the codes can be read this way. Any OBD II reader should work. Some extra ones can only be read by Lotus-specific software unavailable to the public.

Veepeak does the job for me:
https://www.amazon.de /gp/product/B073XKQQQW/

You'll need a compatible App. For iOS / Mac I use "CarScanner"
https://apps.apple.com/de/app/car-scanner-elm-obd2/id1259933623

Usage is simple: Select the scan option, hit scan, and wait for codes to be read. A short description will be shown. You can google the code for more details or ask here - it's probably a known problem.
 
I had this on my new i4 after the first drive. It remained so I took it to the dealership and they said the cause was "indeterminate". They reset it and so far it has not returned. The PPF detailer I used has had a lot of Emiras in and he said that many of them had the CEL lit. It seems to be a very common issue possibly caused by overly sensitive sensors. If it comes back then I will try out my old ODB2 reader to see if I can get a code.
 
The engine light is often caused be a sensor giving a rogue reading - once the error has been logged it stays there in the system log until the garage clears it.

Or - on some occasions it will clear itself.

I have a VW T6 - and I have been plagued with the engine light since new (2018) - in fact it's on right now.

It is often triggered by a long journey, or sometimes going to a different filling station than normal can trigger it.

Sometimes - it will just go out on it's own.

When it was new, it had loads of sensors and bits replaced - but the error has persisted on and off.

VW told me I should take it in every time it comes on - I told them I'd be there every week.


I also bought a cheap ODB reader (about £30) so I could clear the error - often goes away for 6 months or more...
 
  • Thread Starter
  • Thread starter
  • #7
Most of the codes can be read this way. Any OBD II reader should work. Some extra ones can only be read by Lotus-specific software unavailable to the public.

Veepeak does the job for me:
https://www.amazon.de /gp/product/B073XKQQQW/

You'll need a compatible App. For iOS / Mac I use "CarScanner"
https://apps.apple.com/de/app/car-scanner-elm-obd2/id1259933623

Usage is simple: Select the scan option, hit scan, and wait for codes to be read. A short description will be shown. You can google the code for more details or ask here - it's probably a known problem.
Hi, I ordered this and received it yesterday and was able to use it, works perfectly. I was able to remove the error message, the engine light is now off. It appears to be a problem with the ventilation or shutting off of any gasoline vapors. For now, the warning won't come back, so let's hope. So thanks again for the tip, it works perfectly for me! I can now take this information to my garage and see what their answer will be, whether anything needs to be done in terms of maintenance.

130624.jpg
 
Hi, I ordered this and received it yesterday and was able to use it, works perfectly. I was able to remove the error message, the engine light is now off. It appears to be a problem with the ventilation or shutting off of any gasoline vapors. For now, the warning won't come back, so let's hope. So thanks again for the tip, it works perfectly for me! I can now take this information to my garage and see what their answer will be, whether anything needs to be done in terms of maintenance.

View attachment 45722
Wasn't there an issue with the charcoal canister needing to be replaced on some models, or something like that?
 
  • Thread Starter
  • Thread starter
  • #9
Ok warning light is already back. Victory declared too early. Did a reset again, same error message. We'll see what Lotus will do with this.

Icoon voor Geverifieerd door de community
130624 01.jpg
 
I took mine to Bell & Colvill this morning for the engine light.

Apparently I’m the 8th Emira they’ve seen now to have this problem. They found 3 error codes for module related to the braking control, steering column and one I’ve forgotten. A ticket has been registered with Lotus HQ and they did perform a software update but they is no cure at the moment. I was assured that it is purely software related and there was nothing wrong with the car. They cleared the error but I fear the next time it doesn’t start first time the light will come back on.

It only came on after having the intermittent starting issue and that only started after having its first service and software updated 4 weeks ago.
 
  • Thread Starter
  • Thread starter
  • #11
I took mine to Bell & Colvill this morning for the engine light.

Apparently I’m the 8th Emira they’ve seen now to have this problem. They found 3 error codes for module related to the braking control, steering column and one I’ve forgotten. A ticket has been registered with Lotus HQ and they did perform a software update but they is no cure at the moment. I was assured that it is purely software related and there was nothing wrong with the car. They cleared the error but I fear the next time it doesn’t start first time the light will come back on.

It only came on after having the intermittent starting issue and that only started after having its first service and software updated 4 weeks ago.

"and there was nothing wrong with the car"...
I drove more than 10,000 km with that light on and indeed there is nothing wrong with the car, they also told me. But having to look at that light every time I'm driving a new car, I can't handle it anymore. And then not to mention the passengers with always the same comment... hey, your engine light is on? Terrible. :ROFLMAO:

Icoon voor Geverifieerd door de community
 
Decently common part failure on the Emira -- EVAP purge valve is faulty and will need to be replaced.
 
I took mine to Bell & Colvill this morning for the engine light.

Apparently I’m the 8th Emira they’ve seen now to have this problem. They found 3 error codes for module related to the braking control, steering column and one I’ve forgotten. A ticket has been registered with Lotus HQ and they did perform a software update but they is no cure at the moment. I was assured that it is purely software related and there was nothing wrong with the car. They cleared the error but I fear the next time it doesn’t start first time the light will come back on.

It only came on after having the intermittent starting issue and that only started after having its first service and software updated 4 weeks ago.
I had a demo from them the other week and their V6 had the same issue!
 

Similar threads

Back
Top